Click or drag to resize

ManifestTable Class

Maintains an index to every model component that is in the 3dm file. This is the "more comprehensive" table that contains all objects in all other tables.
Inheritance Hierarchy
SystemObject
  Rhino.FileIOManifestTable

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public abstract class ManifestTable : ICommonComponentTable<ModelComponent>, 
	IReadOnlyCollection<ModelComponent>, IEnumerable<ModelComponent>, IEnumerable, 
	ICollection<ModelComponent>

The ManifestTable type exposes the following members.

Properties
  NameDescription
Public propertyComponentType
Returns Mixed.
Public propertyCount
Total number of items in the manifest, including deleted items.
Public propertyLongCount
Total number of items in the manifest, including deleted items.
Public propertyParent
Returns the parent object. This is the RhinoDoc, or the File3md file.
Top
Methods
  NameDescription
Public methodActiveObjectCount
Total number of items in the manifest, including deleted items.
Public methodClear
Marks all items as deleted.
Public methodContains
Determines if an items is contained in this table.
Public methodCopyTo
Copies the content of this table to an array.
Public methodFindId(Guid)
Uses the guid to find a model component. Deleted objects cannot be found by id. The guid is the value that is stored in the .Id property. In a single document, no two active objects have the same guid. If an object is replaced with a new object, then the guid persists. For example, if the _Move command moves an object, then the moved object inherits its guid from the starting object. If the Copy command copies an object, then the copy gets a new guid. This guid persists through file saving/opening operations. This function will not find grip objects.
Public methodFindId(Guid, ModelComponentType)
Uses the guid to find a model component. Deleted objects cannot be found by id. The guid is the value that is stored in the .Id property. In a single document, no two active objects have the same guid. If an object is replaced with a new object, then the guid persists. For example, if the _Move command moves an object, then the moved object inherits its guid from the starting object. If the Copy command copies an object, then the copy gets a new guid. This guid persists through file saving/opening operations. This function will not find grip objects.
Public methodFindIdT(Guid)
Uses the guid to find a model component. Deleted objects cannot be found by id. The guid is the value that is stored in the .Id property. In a single document, no two active objects have the same guid. If an object is replaced with a new object, then the guid persists. For example, if the _Move command moves an object, then the moved object inherits its guid from the starting object. If the Copy command copies an object, then the copy gets a new guid. This guid persists through file saving/opening operations. This function will not find grip objects.
Public methodFindIndex(Int32, ModelComponentType)
Uses the index to find a model component. The index is the value that is stored in the .Index property.
Public methodFindIndexT(Int32)
Uses the index to find a model component. The index is the value that is stored in the .Index property.
Public methodFindName(String, ModelComponentType, Guid)
Uses the name to find a model component. The name is the value that is stored in the .Name property. Deleted objects have no name.
Public methodFindNameT(String, Guid)
Uses the name to find a model component. The name is the value that is stored in the .Name property. Deleted objects have no name.
Public methodFindNameHash(NameHash, ModelComponentType)
Uses the hash of the name to find a model component. Deleted objects have no name.
Public methodFindNameHashT(NameHash)
Uses the hash of the name to find a model component. Deleted objects have no name.
Public methodGetEnumerator
Visits all model components in the document, including default ones.
Public methodGetEnumerator(ModelComponentType)
Returns an enumerators that yields all model components, including default ones, relating to a particular type.
Public methodGetEnumeratorT
Visits all model components in the document, including default ones.
Public methodStatic memberGetModelComponentTypeFromGenericTypeT
Returns the result of the ComponentType property of a ModelComponent.
Top
See Also