File3dmPlugInDataTable Class |
Namespace: Rhino.FileIO
The File3dmPlugInDataTable type exposes the following members.
Name | Description | |
---|---|---|
Count |
Gets the number of File3dmPlugInData objects in this table.
| |
Item |
Gets the File3dmPlugInData object at the given index.
|
Name | Description | |
---|---|---|
Clear |
Remove all entries from this table.
| |
Dump | Prepares a text dump of table. | |
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) | |
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.) | |
GetEnumerator |
Gets the enumerator that visits any File3dmPlugInData in this table.
| |
GetHashCode | Serves as the default hash function. (Inherited from Object.) | |
GetType | Gets the Type of the current instance. (Inherited from Object.) | |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.) | |
ToString | Returns a string that represents the current object. (Inherited from Object.) | |
TryRead |
Attempts to read a Rhino plug-in's custom data from the File3dm file.
|