Click or drag to resize

File3dmThickening Class

Represents the thickening attached to file3dm object attributes.
Inheritance Hierarchy
SystemObject
  Rhino.FileIOFile3dmThickening

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class File3dmThickening

The File3dmThickening type exposes the following members.

Properties
  NameDescription
Public propertyBothSides
Specifies whether to thicken to both sides of the surface.
Public propertyDistance
Specifies how thick meshes will be made.
Public propertyOffsetOnly
Specifies whether to only offset the original surface.
Public propertyOn
Specifies whether the feature is enabled or not.
Public propertySolid
Specifies whether to make open meshes solid by adding walls when thickening.
Top
Methods
  NameDescription
Top
See Also