Click or drag to resize

File3dmWriteOptions Class

Options used by File3dm.Write
Inheritance Hierarchy
SystemObject
  Rhino.FileIOFile3dmWriteOptions

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class File3dmWriteOptions

The File3dmWriteOptions type exposes the following members.

Constructors
  NameDescription
Public methodFile3dmWriteOptions
Initializes properties to defaults.
Top
Properties
  NameDescription
Public propertySaveAnalysisMeshes Obsolete.
Include analysis meshes in the file. Default is true
Public propertySaveRenderMeshes Obsolete.
Include Render meshes in the file. Default is true
Public propertySaveUserData
Include custom user data in the file. Default is true
Public propertyVersion

File version. Default is major version number of this assembly version.

Must be in range [2; current version].

Alternatively, 0 is a placeholder for the last valid version.

Rhino can read its current version, plus earlier file versions except 1.

Use latest version when possible.

Top
Methods
  NameDescription
Public methodEnableAnalysisMeshes
Activates saving of analysis meshes for specific types of objects. If you do not specify the state for an object type, its default is used. Currently SubD mesh saving is disabled by default, while Brep and Extrusion is enabled.
Public methodEnableRenderMeshes
Activates saving of render meshes for specific types of objects. If you do not specify the state for an object type, its default is used. Specifically, currently SubD mesh saving is disabled by default, while Brep and Extrusion is on.
Top
See Also