Click or drag to resize

File3dmCurvePiping Class

Represents the curve piping attached to file3dm object attributes.
Inheritance Hierarchy
SystemObject
  Rhino.FileIOFile3dmCurvePiping

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class File3dmCurvePiping

The File3dmCurvePiping type exposes the following members.

Properties
  NameDescription
Public propertyAccuracy
Specifies the accuracy of the pipe in the range 0 to 100.
Public propertyCapType
Specifies the cap type to use.
Public propertyFaceted
Specifies whether the pipe is faceted or not.
Public propertyOn
Specifies whether curve piping is enabled or not.
Public propertyRadius
Specifies the radius of the pipe (minimum value 0.0001).
Public propertySegments
Specifies the number of segments in the pipe (minimum value 2).
Top
Methods
  NameDescription
Top
See Also