Click or drag to resize

File3dmShutLining Class

Represents the shut-lining attached to file3dm object attributes.
Inheritance Hierarchy
SystemObject
  Rhino.FileIOFile3dmShutLining

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class File3dmShutLining

The File3dmShutLining type exposes the following members.

Properties
  NameDescription
Public propertyAutoUpdate
Specifies whether the shut-lining automatically updates or not.
Public propertyFaceted
Specifies whether the shut-lining is faceted or not.
Public propertyForceUpdate
Specifies whether updating is forced or not.
Public propertyOn
Specifies whether shut-lining is enabled or not.
Top
Methods
  NameDescription
Public methodAddCurve
Adds a new curve to the shut-lining. The curve will have an id of Guid.Empty. After adding a curve, you should set the id to that of a curve in the model that will be used to calculate the shut-lining.
Public methodCurveEnabled
Return whether shut-line is created for the given curve.
Public methodCurveIsBump
Returns whether to create a bump instead of a dent for the given curve.
Public methodCurveProfile
Returns the profile of the shut-line for the given curve.
Public methodCurvePull
Returns whether the given curve is pulled to the surface before creating the shut-line.
Public methodCurveRadius
Returns the radius of the pipe used to create the shut-line for the given curve.
Public methodDeleteAllCurves
Deletes all the curves from the shut-lining.
Public methodGetCurves
Gets all the curves on the shut-lining. Each curve is identified by a Guid. If there are no curves present, the array will be empty.
Public methodSetCurveEnabled
Sets whether shut-line is created for the given curve.
Public methodSetCurveIsBump
Sets whether to create a bump instead of a dent for the given curve.
Public methodSetCurveProfile
Sets the profile of the shut-line for the given curve.
Public methodSetCurvePull
Sets whether the given curve is pulled to the surface before creating the shut-line.
Public methodSetCurveRadius
Sets the radius of the pipe used to create the shut-line for the given curve.
Top
See Also