File3dmShutLining Methods |
The File3dmShutLining type exposes the following members.
Name | Description | |
---|---|---|
![]() | AddCurve |
Adds a new curve to the shut-lining. The curve will have an id of Guid.Empty.
After adding a curve, you should set the id to that of a curve in the model
that will be used to calculate the shut-lining.
|
![]() | CurveEnabled |
Return whether shut-line is created for the given curve.
|
![]() | CurveIsBump |
Returns whether to create a bump instead of a dent for the given curve.
|
![]() | CurveProfile |
Returns the profile of the shut-line for the given curve.
|
![]() | CurvePull |
Returns whether the given curve is pulled to the surface before creating the shut-line.
|
![]() | CurveRadius |
Returns the radius of the pipe used to create the shut-line for the given curve.
|
![]() | DeleteAllCurves |
Deletes all the curves from the shut-lining.
|
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) |
![]() | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.) |
![]() | GetCurves |
Gets all the curves on the shut-lining. Each curve is identified by a Guid.
If there are no curves present, the array will be empty.
|
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object.) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object.) |
![]() | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.) |
![]() | SetCurveEnabled |
Sets whether shut-line is created for the given curve.
|
![]() | SetCurveIsBump |
Sets whether to create a bump instead of a dent for the given curve.
|
![]() | SetCurveProfile |
Sets the profile of the shut-line for the given curve.
|
![]() | SetCurvePull |
Sets whether the given curve is pulled to the surface before creating the shut-line.
|
![]() | SetCurveRadius |
Sets the radius of the pipe used to create the shut-line for the given curve.
|
![]() | ToString | Returns a string that represents the current object. (Inherited from Object.) |