Click or drag to resize

FileXamlWriteOptions Class

Options for writing a Xaml file
Inheritance Hierarchy
SystemObject
  Rhino.FileIOFileXamlWriteOptions

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class FileXamlWriteOptions

The FileXamlWriteOptions type exposes the following members.

Constructors
  NameDescription
Public methodFileXamlWriteOptions
Initializes a new instance of the FileXamlWriteOptions class
Top
Properties
  NameDescription
Public propertyAddRotationAnimation
Public propertyAddRotationScrollbars
Public propertyAnimationAxis
Public propertyMeshingParameters
Public propertyUseExistingRenderMeshes
If render meshes exist they will be used. Otherwise they are created on the fly using the current render settings of the document.
Public propertyUseOriginForRotationCenter
Top
Methods
  NameDescription
Public methodToDictionary
Create a dictionary of these options. This dictionary can be passed to the RhinoDoc.Export function
Top
See Also