Click or drag to resize

File3dmSettings Class

General settings in a 3dm file.
Inheritance Hierarchy
SystemObject
  Rhino.FileIOFile3dmSettings

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class File3dmSettings

The File3dmSettings type exposes the following members.

Properties
  NameDescription
Public propertyModelAbsoluteTolerance
Gets or sets the model space absolute tolerance.
Public propertyModelAngleToleranceDegrees
Gets or sets the model space angle tolerance.
Public propertyModelAngleToleranceRadians
Gets or sets the model space angle tolerance.
Public propertyModelBasepoint
Gets or sets the model base point that is used when the file is read as an instance definition.

This point is mapped to the origin in the instance definition.

Public propertyModelRelativeTolerance
Gets or sets the model space relative tolerance.
Public propertyModelUnitSystem
Gets or sets the model unit system, using UnitSystem enumeration.
Public propertyModelUrl
Gets or sets a Uniform Resource Locator (URL) direction for the model.
Public propertyPageAbsoluteTolerance
Gets or sets the page space absolute tolerance.
Public propertyPageAngleToleranceDegrees
Gets or sets the page space angle tolerance.
Public propertyPageAngleToleranceRadians
Gets or sets the page space angle tolerance.
Public propertyPageRelativeTolerance
Gets or sets the page space relative tolerance.
Public propertyPageUnitSystem
Gets or sets the page unit system, using UnitSystem enumeration.
Public propertyRenderSettings
Gets or sets the render settings.
Top
Methods
  NameDescription
Top
See Also