Click or drag to resize

DracoCompressionOptions Class

Options for applying Draco compression
Inheritance Hierarchy
SystemObject
  Rhino.FileIODracoCompressionOptions

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class DracoCompressionOptions

The DracoCompressionOptions type exposes the following members.

Constructors
  NameDescription
Public methodDracoCompressionOptions
Initializes to default options
Top
Properties
  NameDescription
Public propertyCompressionLevel
Compression level. 0 if fastest, but least compression. 10 is slowest, but best compression
Public propertyNormalQuantizationBits
Sets the quantization compression options for normal values. The values will be quantized in a box defined by the maximum extent of the values. I.e., the actual precision of this option depends on the scale of the attribute values.
Public propertyPositionQuantizationBits
Sets the quantization compression options for position values. The values will be quantized in a box defined by the maximum extent of the values. I.e., the actual precision of this option depends on the scale of the attribute values.
Public propertyTextureCoordintateQuantizationBits
Sets the quantization compression options for texture coordinate values. The values will be quantized in a box defined by the maximum extent of the values. I.e., the actual precision of this option depends on the scale of the attribute values.
Top
Methods
  NameDescription
Top
Fields
  NameDescription
Public fieldIncludeNormals
Include vertex normals in the compressed data.
Public fieldIncludeTextureCoordinates
Include texture coordinates in the compressed data.
Public fieldIncludeVertexColors
Include vertex colors in the compressed data.
Public fieldVertexColorFormat
Color format of vertex colors in compressed data
Top
See Also