Click or drag to resize

File3dmNamedConstructionPlanes Class

Provides access to named construction planes in the 3dm file.
Inheritance Hierarchy
SystemObject
  Rhino.FileIOFile3dmNamedConstructionPlanes

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class File3dmNamedConstructionPlanes : IList<ConstructionPlane>, 
	ICollection<ConstructionPlane>, IEnumerable<ConstructionPlane>, IEnumerable

The File3dmNamedConstructionPlanes type exposes the following members.

Properties
  NameDescription
Public propertyCount
Number of named construction planes in the table.
Public propertyItem
Gets the named construction plane at an index.
Top
Methods
  NameDescription
Public methodAdd(ConstructionPlane)
Adds a named construction plane to the table.
Public methodAdd(String, Plane)
Adds a named construction plane to the table.
Public methodClear
Removes all named construction planes from the table.
Public methodContains
Returns an indication of the presence of a named construction plane in the table.
Public methodCopyTo
Copies the content of the table to an array.
Public methodDelete(ConstructionPlane)
Deletes a named construction plane from the table.
Public methodDelete(Int32)
Remove a named construction plane from the table.
Public methodFindName
Finds a named construction plane given its name.
Public methodGetEnumerator
Gets an enumerator that yields all construction planes in this collection.
Public methodIndexOf
Returns the index of a named construction plane.
Top
See Also