Click or drag to resize

FileObjReadOptions Class

Options used when reading an obj file.
Inheritance Hierarchy
SystemObject
  Rhino.FileIOFileObjReadOptions

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class FileObjReadOptions

The FileObjReadOptions type exposes the following members.

Constructors
  NameDescription
Public methodFileObjReadOptions
Initializes a new instance of the FileObjReadOptions class
Top
Properties
  NameDescription
Public propertyDisplayColorFromObjMaterial
Determines whether textures are read from the .mtl file, if it exists.
Public propertyIgnoreTextures
Determines whether textures are read from the .mtl file, if it exists.
Public propertyMapYtoZ
Setting to transform OBJ's Y axis to Rhino's Z axis
Public propertyMorphTargetOnly
TODO
Public propertyReverseGroupOrder
Determines how groups/layers are nested when reading an obj file. Left to Right (default = false) or Right to Left (true)
Public propertySplit32BitTextures
Public propertyUseObjGroupsAs
Public propertyUseObjObjectsAs
Top
Methods
  NameDescription
Public methodGetTransform
Calculates the YToZ transform.
Top
Fields
  NameDescription
Public fieldReadOptions
Rhino's FileReadOptions passed into ReadFile
Top
See Also