Click or drag to resize

FileWriteOptions Class

[Missing <summary> documentation for "T:Rhino.FileIO.FileWriteOptions"]

Inheritance Hierarchy
SystemObject
  Rhino.FileIOFileWriteOptions

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class FileWriteOptions : IDisposable

The FileWriteOptions type exposes the following members.

Constructors
  NameDescription
Public methodFileWriteOptions
Initializes a new instance of the FileWriteOptions class
Top
Properties
  NameDescription
Public propertyDestinationFileName
For use on Apple frameworks only. Returns the final destination file name.
Public propertyFileVersion
Public propertyIncludeBitmapTable
The file written should include the bitmap table if your File Writing Plug-in supports it.
Public propertyIncludeHistory
The file written should include history information if your File Writing Plug-In supports it.
Public propertyIncludePreviewImage
The file written should include a preview image if your File Writing Plug-in supports it.
Public propertyIncludeRenderMeshes
The file written should include the render meshes if your File Writing Plug-in supports it.
Public propertyOptionsDictionary
Additional read options.
Public propertyRhinoDoc
Source RhinoDoc that is being written
Public propertySuppressAllInput
Public propertySuppressDialogBoxes
If true, it means the command has been run with a '-', meaning you should not ask questions during writing. (no dialogs, no "getters", etc.)
Public propertyUpdateDocumentPath
If a complete, current version, 3dm file is successfully saved, then the name of the file will be used to update the document's default file path and title and document will be marked as not modified.
Public propertyWriteAsTemplate
Write as template
Public propertyWriteGeometryOnly
If true, the file written should include only geometry File Writing Plug-in supports it.
Public propertyWriteSelectedObjectsOnly
If true, this command should export only the objects currently selected in the Rhino model.
Public propertyWriteUserData
If true, the file written should include User Data if your File Writing Plug-in supports it.
Public propertyXform
Top
Methods
  NameDescription
Public methodDispose
Releases all resources used by the FileWriteOptions
Protected methodDispose(Boolean)
Releases the unmanaged resources used by the FileWriteOptions and optionally releases the managed resources
Protected methodFinalize (Overrides ObjectFinalize.)
Top
See Also