Click or drag to resize

File3dmMeshModifiers Class

Represents the mesh modifiers attached to file3dm object attributes.
Inheritance Hierarchy
SystemObject
  Rhino.FileIOFile3dmMeshModifiers

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class File3dmMeshModifiers

The File3dmMeshModifiers type exposes the following members.

Properties
  NameDescription
Public propertyCurvePiping
Returns an object that provides access to curve piping information. If no curve piping information is present, the method returns null.
Public propertyDisplacement
Returns an object that provides access to displacement information. If no displacement information is present, the method returns null.
Public propertyEdgeSoftening
Returns an object that provides access to edge softening information. If no edge softening information is present, the method returns null.
Public propertyShutLining
Returns an object that provides access to shut-lining information. If no shutlining information is present, the method returns null.
Public propertyThickening
Returns an object that provides access to thickening information. If no thickening information is present, the method returns null.
Top
Methods
  NameDescription
Top
See Also