Click or drag to resize

NameHash Class

Contains information that is useful to uniquely identify an object name.
Remarks
This object is immutable.
Inheritance Hierarchy
SystemObject
  Rhino.FileIONameHash

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class NameHash : ICloneable, IEquatable<NameHash>

The NameHash type exposes the following members.

Constructors
  NameDescription
Protected methodNameHash(NameHash)
Constructs a copy of a content hash.
Public methodNameHash(String)
Creates a new NameHash, representing a piece of text.
Public methodNameHash(String, Guid)
Creates a new NameHash, representing a piece of text.
Public methodNameHash(String, Guid, ModelComponentType)
Creates a new NameHash, representing a piece of text.
Public methodNameHash(String, Guid, Boolean)
Creates a new NameHash, representing a piece of text.
Top
Properties
  NameDescription
Public propertyMappedCodePoints
Gets the NameHash flags. In some cases = number of mapped code points.
Public propertyParentId
Only useful if this participates in a tree structure, as with layers.
Public propertySha1Hash
Gets the 20-bytes long SHA-1 hash of ordinal minimum mapped Unicode (UTF-32) code points.
Top
Methods
  NameDescription
Public methodClone
Creates a copy of this name hash. Because content hash is immutable, this can be used as a deep copy.
Public methodStatic memberCreateFilePathHash
Creates a new NameHash, representing the name of a file.
Public methodEquals(NameHash)
Determines if another name hash has the same value.
Public methodEquals(Object)
Determines if another object is a name hash with same value.
(Overrides ObjectEquals(Object).)
Public methodGetHashCode
Gets an hash code for this name hash. Two equal content hashes have equal hash code. The other way around might not be true.
(Overrides ObjectGetHashCode.)
Top
Operators
  NameDescription
Public operatorStatic memberEquality
Determines if two NameHash instances are equal by value.
Public operatorStatic memberInequality
Determines if two NameHash instances are different by value.
Top
See Also