Click or drag to resize

NameHash Methods

The NameHash type exposes the following members.

Methods
  NameDescription
Public methodClone
Creates a copy of this name hash. Because content hash is immutable, this can be used as a deep copy.
Public methodStatic memberCreateFilePathHash
Creates a new NameHash, representing the name of a file.
Public methodEquals(NameHash)
Determines if another name hash has the same value.
Public methodEquals(Object)
Determines if another object is a name hash with same value.
(Overrides ObjectEquals(Object).)
Public methodGetHashCode
Gets an hash code for this name hash. Two equal content hashes have equal hash code. The other way around might not be true.
(Overrides ObjectGetHashCode.)
Top
See Also