Click or drag to resize

File3dmViewTable Class

Provides access to views in the 3dm file.
Inheritance Hierarchy
SystemObject
  Rhino.FileIOFile3dmViewTable

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class File3dmViewTable : IList<ViewInfo>, 
	ICollection<ViewInfo>, IEnumerable<ViewInfo>, IEnumerable

The File3dmViewTable type exposes the following members.

Properties
  NameDescription
Public propertyCount
Gets the amount of items in the table.
Public propertyItem
Gets the view info at an index. The set method always throws NotSupportedException.
Top
Methods
  NameDescription
Public methodAdd
Adds a
Public methodClear
Removes all items from the table.
Public methodContains
Returns an indication of the presence of a view in the table.
Public methodCopyTo
Copies the content of the table to an array.
Public methodDelete(Int32)
Removes an item.
Public methodDelete(ViewInfo)
Deletes an item.
Public methodFindName
Finds a ViewInfo given its name.
Public methodGetEnumerator
Returns an enumerator that yields all views in the table.
Public methodIndexOf
Returns the index of the current ViewInfo.
Top
See Also