Click or drag to resize

File3dmDisplacement Class

Represents the displacement attached to file3dm object attributes.
Inheritance Hierarchy
SystemObject
  Rhino.FileIOFile3dmDisplacement

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class File3dmDisplacement

The File3dmDisplacement type exposes the following members.

Properties
  NameDescription
Public propertyBlackPoint
Specifies the amount of displacement for the black color in the texture.
Public propertyFairing
Specifies the number of steps for the fairing process. Fairing straightens rough feature edges.
Public propertyFairingOn
Specifies whether or not to perform a fairing step. Fairing straightens rough feature edges.
Public propertyFinalMaxFaces
Specifies how many faces the reduction post process should target.
Public propertyFinalMaxFacesOn
Specifies whether to perform a mesh reduction as a post process to simplify the result of displacement.
Public propertyInitialQuality
Specifies how densely the object is initially subdivided. The lower the value, the higher the resolution of the displaced mesh.
Public propertyMappingChannel
Specifies which texture mapping channel is used for the displacement texture.
Public propertyMeshMemoryLimit
Specifies in megabytes how much memory can be allocated for use by the displacement mesh.
Public propertyOn
Specifies whether the displacement feature is enabled or not.
Public propertyPostWeldAngle
Specifies the maximum angle between face normals of adjacent faces that will get welded together.
Public propertyRefineSensitivity
Specifies how sensitive the divider for contrasts is on the displacement texture. Specify 1 to split all mesh edges on each refine step. Specify 0.99 to make even slight contrasts on the displacement texture cause edges to be split. Specifying 0.01 only splits edges where heavy contrast exists.
Public propertyRefineSteps
Specifies the number of refinement passes
Public propertySweepResolutionFormula
Specifies which formula is used to calculate sweep resolution from initial quality.
Public propertyTextureId
Specifies which texture is used for computing the displacement amount.
Public propertyWhitePoint
Specifies the amount of displacement for the white color in the texture.
Top
Methods
  NameDescription
Public methodAddSubItem
Adds a new sub-item to the displacement. face_index is the index of the face on the polysurface/SubD.on is the override for File3dmDisplacement.On.texture is the override for File3dmDisplacement.TextureId.mapping_channel is the override for File3dmDisplacement.MappingChannel.black_point is the override for File3dmDisplacement.BlackPoint.white_point is the override for File3dmDisplacement.WhitePoint.
Public methodDeleteAllSubItems
Deletes all the sub-items from the displacement.
Public methodDeleteSubItem
Deletes a sub-item by its face index. face_index is the index of the face on the polysurface/SubD.
Public methodGetSubItemFaceIndexes
Gets all the sub-items on the displacement. Sub-items can exist to override the top-level parameters for polysurface/SubD faces. Sub-items are identified by the face index that they apply to. An array of the face indexes of each sub-item on the displacement.
Public methodSetSubItemBlackPoint
Sets the override for displacement 'black-point'. face_index is the index of the face on the polysurface/SubD.
Public methodSetSubItemMappingChannel
Sets the override for displacement 'mapping channel'. face_index is the index of the face on the polysurface/SubD.
Public methodSetSubItemOn
Sets the override for displacement 'on'. face_index is the index of the face on the polysurface/SubD.
Public methodSetSubItemTexture
Sets the override for displacement 'texture'. face_index is the index of the face on the polysurface/SubD.
Public methodSetSubItemWhitePoint
Sets the override for displacement 'white-point'. face_index is the index of the face on the polysurface/SubD.
Public methodSubItemBlackPoint
Gets the override for displacement 'black-point'. face_index is the index of the face on the polysurface/SubD.
Public methodSubItemMappingChannel
Gets the override for displacement 'mapping channel'. face_index is the index of the face on the polysurface/SubD.
Public methodSubItemOn
Gets the override for displacement 'on'. face_index is the index of the face on the polysurface/SubD.
Public methodSubItemTexture
Gets the override for displacement 'texture'. face_index is the index of the face on the polysurface/SubD.
Public methodSubItemWhitePoint
Gets the override for displacement 'white-point'. face_index is the index of the face on the polysurface/SubD.
Top
See Also