Click or drag to resize

File3dmDisplacement Properties

The File3dmDisplacement type exposes the following members.

Properties
  NameDescription
Public propertyBlackPoint
Specifies the amount of displacement for the black color in the texture.
Public propertyFairing
Specifies the number of steps for the fairing process. Fairing straightens rough feature edges.
Public propertyFairingOn
Specifies whether or not to perform a fairing step. Fairing straightens rough feature edges.
Public propertyFinalMaxFaces
Specifies how many faces the reduction post process should target.
Public propertyFinalMaxFacesOn
Specifies whether to perform a mesh reduction as a post process to simplify the result of displacement.
Public propertyInitialQuality
Specifies how densely the object is initially subdivided. The lower the value, the higher the resolution of the displaced mesh.
Public propertyMappingChannel
Specifies which texture mapping channel is used for the displacement texture.
Public propertyMeshMemoryLimit
Specifies in megabytes how much memory can be allocated for use by the displacement mesh.
Public propertyOn
Specifies whether the displacement feature is enabled or not.
Public propertyPostWeldAngle
Specifies the maximum angle between face normals of adjacent faces that will get welded together.
Public propertyRefineSensitivity
Specifies how sensitive the divider for contrasts is on the displacement texture. Specify 1 to split all mesh edges on each refine step. Specify 0.99 to make even slight contrasts on the displacement texture cause edges to be split. Specifying 0.01 only splits edges where heavy contrast exists.
Public propertyRefineSteps
Specifies the number of refinement passes
Public propertySweepResolutionFormula
Specifies which formula is used to calculate sweep resolution from initial quality.
Public propertyTextureId
Specifies which texture is used for computing the displacement amount.
Public propertyWhitePoint
Specifies the amount of displacement for the white color in the texture.
Top
See Also