Click or drag to resize

File3dmDisplacement Methods

The File3dmDisplacement type exposes the following members.

Methods
  NameDescription
Public methodAddSubItem
Adds a new sub-item to the displacement. face_index is the index of the face on the polysurface/SubD.on is the override for File3dmDisplacement.On.texture is the override for File3dmDisplacement.TextureId.mapping_channel is the override for File3dmDisplacement.MappingChannel.black_point is the override for File3dmDisplacement.BlackPoint.white_point is the override for File3dmDisplacement.WhitePoint.
Public methodDeleteAllSubItems
Deletes all the sub-items from the displacement.
Public methodDeleteSubItem
Deletes a sub-item by its face index. face_index is the index of the face on the polysurface/SubD.
Public methodGetSubItemFaceIndexes
Gets all the sub-items on the displacement. Sub-items can exist to override the top-level parameters for polysurface/SubD faces. Sub-items are identified by the face index that they apply to. An array of the face indexes of each sub-item on the displacement.
Public methodSetSubItemBlackPoint
Sets the override for displacement 'black-point'. face_index is the index of the face on the polysurface/SubD.
Public methodSetSubItemMappingChannel
Sets the override for displacement 'mapping channel'. face_index is the index of the face on the polysurface/SubD.
Public methodSetSubItemOn
Sets the override for displacement 'on'. face_index is the index of the face on the polysurface/SubD.
Public methodSetSubItemTexture
Sets the override for displacement 'texture'. face_index is the index of the face on the polysurface/SubD.
Public methodSetSubItemWhitePoint
Sets the override for displacement 'white-point'. face_index is the index of the face on the polysurface/SubD.
Public methodSubItemBlackPoint
Gets the override for displacement 'black-point'. face_index is the index of the face on the polysurface/SubD.
Public methodSubItemMappingChannel
Gets the override for displacement 'mapping channel'. face_index is the index of the face on the polysurface/SubD.
Public methodSubItemOn
Gets the override for displacement 'on'. face_index is the index of the face on the polysurface/SubD.
Public methodSubItemTexture
Gets the override for displacement 'texture'. face_index is the index of the face on the polysurface/SubD.
Public methodSubItemWhitePoint
Gets the override for displacement 'white-point'. face_index is the index of the face on the polysurface/SubD.
Top
See Also