Click or drag to resize

ICommonComponentTableT Interface

Provides methods to use all File3dm and RhinoDoc tables under the same contract. Do not derive from this interface. This is to ensure all tables can be used with the same method list.

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public interface ICommonComponentTable<T> : IReadOnlyCollection<T>, 
	IEnumerable<T>, IEnumerable, ICollection<T>
where T : ModelComponent

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Rhino.FileIO.ICommonComponentTable`1"]

The ICommonComponentTableT type exposes the following members.

Properties
  NameDescription
Public propertyComponentType
Returns the model component type the table handles.
Top
Methods
  NameDescription
Public methodFindId
Retrieves an object based on ID. You should prefer ID search over Index search.
Public methodFindNameHash
Retrieves an object based on Name.
Top
See Also