Click or drag to resize

File3dmStringTable Class

Provides access to document strings in the 3dm file.
Inheritance Hierarchy
SystemObject
  Rhino.FileIOFile3dmStringTable

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class File3dmStringTable

The File3dmStringTable type exposes the following members.

Properties
  NameDescription
Public propertyCount
Returns the number of document strings in the 3dm file.
Public propertyDocumentUserTextCount
Returns the number of Section/Entry-style key values.
Top
Methods
  NameDescription
Public methodDelete(String)
Removes a document string from the 3dm file.
Public methodDelete(String, String)
Removes document strings from the 3dm file.
Public methodGetEntryNames
Return list of all entry names for a given section of document strings in the 3dm file.
Public methodGetKey
Returns a key value at a given index.
Public methodGetSectionNames
Returns a list of all the section names for document strings in the 3dm file.

By default a section name is a key that is prefixed with a string separated by a backslash.

Public methodGetValue(Int32)
Returns a string value at a given index.
Public methodGetValue(String)
Returns a string value at a key.
Public methodGetValue(String, String)
Returns a string value given a section and entry.
Public methodSetString(String, String)
Adds or sets a a document string in the 3dm file.
Public methodSetString(String, String, String)
Adds or sets a document string in the 3dm file.
Top
See Also