Click or drag to resize

FileIgsWriteOptions Class

Options for writing a Igs file
Inheritance Hierarchy
SystemObject
  Rhino.FileIOFileIgsWriteOptions

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class FileIgsWriteOptions

The FileIgsWriteOptions type exposes the following members.

Constructors
  NameDescription
Public methodFileIgsWriteOptions
Initializes a new instance of the FileIgsWriteOptions class
Top
Properties
  NameDescription
Public propertyAuthor
Public propertyCatiaTolsize
Public propertyCatiaVersion
Public propertyClampCurveEndKnots
TRUE means all periodic NURBS will have their end knots clamped.
Public propertyClampSurfaceEndKnots
Public propertyCompositeCurvesAsSingleBsplines
Public propertyCurveMaxDegree
d >= 3 means all NURBS curves with degree > d be fit with degree d non-rational cubics.
Public propertyDoublesUseE
Use "E" instead of the correct "D" for double scientific notation to get around IGES bug in FastShip.
Public propertyEolType
IGES files are ASCII files. You need to specify the flavor of the ASCII end of line marker.Possibilities are: TL_LF: line feed (unix) TL_CRLF: carriage return, line feed (Microsoft) TL_CR: carriage return (Apple)
Public propertyFitRationalCurves
true means all rational NURBS will be fit with non-rational cubics.
Public propertyFitRationalSurfaces
true means non-conic rational surfaces will be fit with non-rational surfaces
Public propertyFlagDependentCurvesAs03
Public propertyFlagDependentSurfacesAs03
Public propertyForceBezierKnotsOnCurves
Public propertyForceBezierKnotsOnSurfaces
true means all NURBS surfaces will have their internal knots set to full multiplicity.
Public propertyForceTrimmedSurfaces
true means all surfaces will be exported as 143 or 144s CATIA may like this better.
Public propertyHideDependentObjects
Public propertyIgesStringType
Public propertyIgesVersion
Version of IGES spec to write
Public propertyMaxSurfaceDegree
Public propertyMeshType
Public propertyNotesInStartSection
Public propertyNoZerosInTSection
The GridTool program used at NASA Langly cannot read IGES files that have leading zeros in the T section.
Public propertyOrganization
Public propertyPointType
Public propertyPolySurfaceType
Public propertyReceiver
Public propertyRenderColorAsIgesColor
Public propertyScale
(model space units)/(real world units) For example, if unit_system = TL_INCHES and 1 model space unit = 8 inches, then scale = 0.125.Note that model space units are stored in the IGES file.
Public propertySender
Public propertySimplifyCurves
TRUE means NURBS that are lines or arcs will be written as lines or arcs instead of 126's
Public propertySimplifySurfaces
true means that NURBS surfaces that are ruled surfaces or surfaces of revolution will be written as ruled surfaces or surfaces of revolution.
Public propertySolidType
Public propertySplitBiPolarSurfaces
Public propertySplitClosedSurfaces
Public propertySurfaceType
Public propertyTolerance
In model space units specified above
Public propertyUnits
Public propertyUseParentLabelOnCurves
copy parent label to dependent curves
Public propertyUseParentLabelOnSurfaces
copy parent label to dependent srfs
Public propertyWriteNonPlanarUnitNormal
true means the UnitNormal will be written regardless, even if the curve is non planar
Top
Methods
  NameDescription
Public methodToDictionary
Create a dictionary of these options. This dictionary can be passed to the RhinoDoc.Export function
Top
See Also