Click or drag to resize

FileObjWriteOptions Class

[Missing <summary> documentation for "T:Rhino.FileIO.FileObjWriteOptions"]

Inheritance Hierarchy
SystemObject
  Rhino.FileIOFileObjWriteOptions

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class FileObjWriteOptions

The FileObjWriteOptions type exposes the following members.

Constructors
  NameDescription
Public methodFileObjWriteOptions
Initializes a new instance of the FileObjWriteOptions class
Top
Properties
  NameDescription
Public propertyActualFilePathOnMac
Public propertyCreateNgons Obsolete.
Setting to enable/disable the creation of ngons for the output
Public propertyCullUnnecessaryVertexesInNgons
Setting to determine whether interior collinear vertexes are part of the ngon.
Public propertyEolType
Public propertyExportAsTriangles
Enable/disable export of faces as triangles.
Public propertyExportGroupNameLayerNames
Setting to determine whether object, group or layer names will become "g"s in the OBJ output file
Public propertyExportMaterialDefinitions
Setting to write an .mtl file and "usemtl"s in the obj file
Public propertyExportNormals
Enable/disable export of vertex normals, if they exist.
Public propertyExportObjectNames
Setting to determine what object names in Rhino will become in the OBJ output file
Public propertyExportOpenMeshes
Enable/Disable bailing when an open mesh is encountered.
Public propertyExportTcs
Enable/disable export of texture coordinates, if they exist.
Public propertyExportVcs
Enable/disable export of vertex colors, if they exist.
Public propertyIncludeUnweldedEdgesInNgons
Setting to determine whether unwelded edges are ignored in the creation of an ngon.
Public propertyMapZtoY
Setting to transform Rhino's Z axis to OBJ's Y axis
Public propertyMergeNestedGroupingNames
Setting to merge nested layer or group names into a single OBJ group name
Public propertyMeshParameters
Mesh parameters to use when meshing geometry that is not already a mesh.
Public propertyMeshType
Public propertyMinNgonFaceCount
Minimum number of faces to consider creation of ngon
Public propertyNgonMode
Public propertyObjectType
Public propertyPolylineType
Public propertySignificantDigits
Number of significant digits to write out for floating point numbers
Public propertySortObjGroups
Setting to enable/disable sorting of OBJ groups
Public propertySubDMeshType
Public propertySubDSurfaceMeshingDensity
Determines how coarse the mesh output will be when surface meshing subd objects See comments for ON_SubDDisplayParameters in opennurbs_mesh.h for details regarding numbers used.
Public propertyTrimCurveType
trimming curve option
Public propertyUnderbarMaterialNames
Enable/disable replacing white space with under-bars in material names.
Public propertyUseDisplayColorForMaterial
Setting to display color as material when material index for object is -1.
Public propertyUseRelativeIndexing
Determines whether to use relative indexing. TRUE = use relative (negative) indexing FALSE = use absolute (positive) indexing
Public propertyUseRenderMeshes
Use existing or generate render meshes instead of calling RhinoObject.MeshObjects.
Public propertyUseSimpleDialog
Determines whether to use the simple or detailed meshing dialog.
Public propertyVcsFormat
Export vertex colors as 0 == floats (0.0-1.0) or 1 == ints (0-255)
Public propertyWrapLongLines
Setting to enable/disable line wrapping with "\"s
Top
Methods
  NameDescription
Public methodGetTransform
Calculates the transform combination of ZToY and any the translation that might occur in a SavewithOrigin.
Top
Fields
  NameDescription
Public fieldAngleTolRadians
If trim is TL_OBJ_FILE_TRIM_POLYLINE, angle_tol (in radians) controls the level of linearization on parameter space trimming curves.
Public fieldWriteOptions
Top
See Also