Click or drag to resize

SerializationOptions Class

Contains options for serializing -or storing- data, such as Rhino version, user data, and meshes.
Inheritance Hierarchy
SystemObject
  Rhino.FileIOSerializationOptions

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class SerializationOptions

The SerializationOptions type exposes the following members.

Constructors
  NameDescription
Public methodSerializationOptions
Initializes a new instance of the SerializationOptions class.
Top
Properties
  NameDescription
Public propertyRhinoVersion
Gets or sets a value indicating the Rhino version.
Public propertyWriteAnalysisMeshes
Gets or sets a value indicating whether to write analysis meshes
Public propertyWriteRenderMeshes
Gets or sets a value indicating whether to write render meshes
Public propertyWriteUserData
Gets or sets a value indicating whether to write user data.
Top
Methods
  NameDescription
Top
See Also