Click or drag to resize

FileDwgWriteOptions Class

Options for writing a DWG file
Inheritance Hierarchy
SystemObject
  Rhino.FileIOFileDwgWriteOptions

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class FileDwgWriteOptions

The FileDwgWriteOptions type exposes the following members.

Constructors
  NameDescription
Public methodFileDwgWriteOptions
Initializes a new instance of the FileDwgWriteOptions class
Top
Properties
  NameDescription
Public propertyColorMethod
pallette index: clrACI, RGB: clrRGB
Public propertyCurveChordHeight
Absolute distance from pline to nurb
Public propertyCurveMaxAngleDegrees
Angle between pline segments in writing curve
Public propertyCurveMaxAngleRadians
Angle between pline segments in writing curve
Public propertyCurveSegmentLength
Max length for any polyline segment
Public propertyCurveUseChordHeight
Public propertyCurveUseMaxAngle
Public propertyCurveUseSegmentLength
Public propertyExportArcsAs
Public propertyExportLinesAs
Public propertyExportMeshesAs
Rhino meshes as polyface meshes or 3dfaces
Public propertyExportPolycurvesAs
Public propertyExportPolylinesAs
Public propertyExportSplinesAs
Public propertyExportSurfacesAs
Rhino surcaces as meshes(0) or curves(1) or acis(2)
Public propertyFlatten
Project to cplane or view
Public propertyFullLayerPath
write layernames as Parent$Child or Child
Public propertyIsDefault
Public propertyMinPointDistance
Public propertyNoDxfHeader
write an entities only dxf file ( R12 only)
Public propertyPreserveArcNormals
Users wanted to use Pedit in AutoCAD to join them into plines and that didn't work if the normals of arcs being joined are different. Default will be true and will change the behavior
Public propertySimplify
use lines and arcs where possible
Public propertySimplifyTolerance
Public propertySplitPolycurves
Explode polycurves before exporting
Public propertySplitSplines
Split splines at FMKs before exporting
Public propertyUseLWPolylines
Public propertyVersion
Version of DWG file to write
Top
Methods
  NameDescription
Public methodToDictionary
Create a dictionary of these options. This dictionary can be passed to the RhinoDoc.Export function
Top
See Also