Click or drag to resize

FileSlcWriteOptions Class

Options used when writing a SLC file
Inheritance Hierarchy
SystemObject
  Rhino.FileIOFileSlcWriteOptions

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class FileSlcWriteOptions

The FileSlcWriteOptions type exposes the following members.

Constructors
  NameDescription
Public methodFileSlcWriteOptions
Initializes a new instance of the FileSlcWriteOptions class
Top
Properties
  NameDescription
Public propertyAngleBetweenSegmentsDegrees
The angle that determines how smooth the polylines of the slice curves will be. When the number is small you will get a smooth final output but it will take more time to export and a larger file.
Public propertyEndPoint
End of the slicing normal
Public propertySliceDistance
The distance between the slices or layers of curves that your final output will contain. The distance should be based on the slice thickness of your final output device
Public propertyStartPoint
Start of the slicing normal
Public propertyUseMeshes
Use meshes to generate slices. The curves for each slice are generated by intersecting the object mesh with a plane. the Angle between polyline segments data is not used when this value is true
Top
Methods
  NameDescription
Top
See Also