Click or drag to resize

FileGltfWriteOptions Class

Options used when writing a glTF file
Inheritance Hierarchy
SystemObject
  Rhino.FileIOFileGltfWriteOptions

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 8.3
Syntax
public class FileGltfWriteOptions

The FileGltfWriteOptions type exposes the following members.

Constructors
  NameDescription
Public methodFileGltfWriteOptions
Initializes a new instance of the FileGltfWriteOptions class
Top
Properties
  NameDescription
Public propertyCullBackfaces
Setting that determines whether or not the meshes in the glTF will be rendered with or without backface culling. Known as DoubleSided in the glTF specification.
Public propertyDracoCompressionLevel
The level of compression used by draco in the range of 1 to 10 inclusive.
Public propertyDracoQuantizationBitsNormal
The number of bits used when quantizing mesh normals in the range of 8 to 32 inclusive
Public propertyDracoQuantizationBitsPosition
The number of bits used when quantizing mesh vertex positions in the range of 8 to 32 inclusive
Public propertyDracoQuantizationBitsTextureCoordinate
The number of bits used when quantizing mesh texture coordinates in the range of 8 to 32 inclusive
Public propertyExportLayers
glTF uses a scene hierarchy structure where nodes are organized in a parent-child relationship. This setting enables/disables the writing of empty nodes with the same names as layers and places exported objects a children of the corresponding layer node.
Public propertyExportMaterials
Setting to determine whether or not materials are written to the glTF file
Public propertyExportOpenMeshes
Enable/disable the exporting of open meshes
Public propertyExportTextureCoordinates
Enable/disable the exporting of texture coordinates
Public propertyExportVertexColors
Enable/disable the export of vertex colors
Public propertyExportVertexNormals
Enable/disable the exporting of vertex normals
Public propertyMapZToY
Setting to transform Rhino's Z axis to glTF's Y axis
Public propertySubDMeshType
The mesh type for exported SubDs
Public propertySubDSurfaceMeshingDensity
Determines how coarse the mesh output will be when surface meshing subd objects See comments for ON_SubDDisplayParameters in opennurbs_mesh.h for details regarding numbers used.
Public propertyUseDisplayColorForUnsetMaterials
Setting to display color as material when material index for object is -1.
Public propertyUseDracoCompression
Enable/disable the use of Draco mesh compression in the glTF file
Top
Methods
  NameDescription
Public methodToDictionary
Create a dictionary of these options. This dictionary can be passed to the RhinoDoc.Export function
Top
See Also