Click or drag to resize

FileStpWriteOptions Class

Options used when writing a STP file
Inheritance Hierarchy
SystemObject
  Rhino.FileIOFileStpWriteOptions

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class FileStpWriteOptions

The FileStpWriteOptions type exposes the following members.

Constructors
  NameDescription
Public methodFileStpWriteOptions
Initializes a new instance of the FileStpWriteOptions class
Top
Properties
  NameDescription
Public propertyExport2dCurves
Some (not most, and not Rhino) importing applications can make use of the 2-D trimming curves to get a more accurate and faster import. The size of the step file will be larger
Public propertyExportBlack
Let importing application set color for black objects. If a Rhino object has color black, no color is assigned to the object in the step file.This will cause the importing application to give the object its default color.This is desirable because black objects look like ink blots in some applications.This option is grayed out if the schema option is AP203ControConfigDesign since that schema does not include color entities.
Public propertySchema
Get and set the schema of the step file being written.
Public propertySplitClosedSurfaces
Splits closed surfaces, for example, the interior surfaces of drilled holes.
Top
Methods
  NameDescription
Public methodToDictionary
Create a dictionary of these options. This dictionary can be passed to the RhinoDoc.Export function
Top
See Also