Click or drag to resize

DisplayPipeline Methods

The DisplayPipeline type exposes the following members.

Methods
  NameDescription
Public methodAddClippingPlane
Add a clipping plane to be used during the drawing of this frame
Public methodStatic memberAvailableOpenGLVersion
If Rhino is using OpenGL for display, this function will return major.minor version of OpenGL available for this instance of Rhino
Public methodClearFrameBuffer
Fill the frame buffer with a single color. This function also clears the depth buffer for engines that support depth buffered drawing.
Public methodClone
Clones the pipeline. Creates an identical copy of "this" pipeline. Copies all conduits from "this" pipeline to the new pipeline.
Public methodClose
Closes the pipeline.
Public methodStatic memberCullControlPolygon
Returns a value indicating if only points on the side of the surface that face the camera are displayed.
Public methodDraw2dLine(Point, Point, Color, Single)
Public methodDraw2dLine(PointF, PointF, Color, Single)
Public methodDraw2dRectangle
Public methodCode exampleDraw2dText(String, Color, Point2d, Boolean)
Draws 2D text on the viewport.
Public methodDraw2dText(String, Color, Point3d, Boolean)
Draws 2D text on the viewport.
Public methodDraw2dText(String, Color, Point2d, Boolean, Int32)
Draws 2D text on the viewport.
Public methodDraw2dText(String, Color, Point3d, Boolean, Int32)
Draws 2D text on the viewport.
Public methodDraw2dText(String, Color, Point2d, Boolean, Int32, String)
Draws 2D text on the viewport.
Public methodDraw2dText(String, Color, Point3d, Boolean, Int32, String)
Draws 2D text on the viewport.
Public methodDraw3dText(Text3d, Color)
Public methodDraw3dText(Text3d, Color, Plane)
Draws 3d text with a different plane than what is defined in the Text3d class.
Public methodDraw3dText(Text3d, Color, Point3d)
Draws 3d text using the Text3d plane with an adjusted origin.
Public methodDraw3dText(String, Color, Plane, Double, String)
Public methodDraw3dText(String, Color, Plane, Double, String, Boolean, Boolean)
Public methodDraw3dText(String, Color, Plane, Double, String, Boolean, Boolean, TextHorizontalAlignment, TextVerticalAlignment)
Public methodDrawActivePoint
Draws a point in style used during "GetPoint" operations
Public methodDrawAnnotation
Public methodDrawAnnotationArrowhead
Public methodDrawArc(Arc, Color)
Draw a single arc object.
Public methodDrawArc(Arc, Color, Int32)
Draw a single arc object.
Public methodDrawArrow(Line, Color)
Draws a single arrow object. An arrow consists of a Shaft and an Arrow head at the end of the shaft.
Public methodCode exampleDrawArrow(Line, Color, Double, Double)
Draws a single arrow object. An arrow consists of a Shaft and an Arrow head at the end of the shaft.
Public methodDrawArrowHead
Draws a single arrow head.
Public methodDrawArrows(IEnumerableLine, Color)
Draws a collection of arrow objects. An arrow consists of a Shaft and an Arrow head at the end of the shaft.
Public methodDrawArrows(Line, Color)
Draws a collection of arrow objects. An arrow consists of a Shaft and an Arrow head at the end of the shaft.
Public methodCode exampleDrawBitmap
Draws a bitmap in screen coordinates
Public methodDrawBox(BoundingBox, Color)
Draws the edges of a BoundingBox.
Public methodDrawBox(Box, Color)
Draws the edges of a Box object.
Public methodDrawBox(BoundingBox, Color, Int32)
Draws the edges of a BoundingBox.
Public methodDrawBox(Box, Color, Int32)
Draws the edges of a Box object.
Public methodDrawBoxCorners(BoundingBox, Color)
Draws corner widgets of a world aligned bounding box. Widget size will be 5% of the Box diagonal.
Public methodDrawBoxCorners(BoundingBox, Color, Double)
Draws corner widgets of a world aligned bounding box.
Public methodDrawBoxCorners(BoundingBox, Color, Double, Int32)
Draws corner widgets of a world aligned bounding box.
Public methodDrawBrepShaded
Draws a shaded mesh representation of a brep.
Public methodDrawBrepWires(Brep, Color)
Draws all the wireframe curves of a brep object.
Public methodDrawBrepWires(Brep, Color, Int32)
Draws all the wireframe curves of a brep object.
Public methodCode exampleDrawCircle(Circle, Color)
Draw a single circle object.
Public methodDrawCircle(Circle, Color, Int32)
Draw a single circle object.
Public methodDrawCone(Cone, Color)
Draw a wireframe cone.
Public methodDrawCone(Cone, Color, Int32)
Draw a wireframe cone.
Public methodDrawConstructionPlane
Draws a construction plane.
Public methodDrawCurvatureGraph(Curve, Color)
Draw a typical Rhino Curvature Graph.
Public methodDrawCurvatureGraph(Curve, Color, Int32)
Draw a typical Rhino Curvature Graph.
Public methodDrawCurvatureGraph(Curve, Color, Int32, Int32, Int32)
Draw a typical Rhino Curvature Graph.
Public methodDrawCurve(Curve, DisplayPen)
Public methodDrawCurve(Curve, Color)
Draw a single Curve object.
Public methodDrawCurve(Curve, Color, Int32)
Draw a single Curve object.
Public methodDrawCylinder(Cylinder, Color)
Draw a wireframe cylinder.
Public methodDrawCylinder(Cylinder, Color, Int32)
Draw a wireframe cylinder.
Public methodDrawDirectionArrow
Public methodDrawDot(Point3d, String)
Draws a text dot in world coordinates.
Public methodDrawDot(Single, Single, String)
Draws a text dot in screen coordinates.
Public methodDrawDot(Point3d, String, Color, Color)
Draw a text dot in world coordinates.
Public methodDrawDot(TextDot, Color, Color, Color)
Draw a text dot as defined by the text dot class
Public methodDrawDot(Single, Single, String, Color, Color)
Draws a text dot in screen coordinates.
Public methodDrawDottedLine(Line, Color)
Draws a single dotted line.
Public methodDrawDottedLine(Point3d, Point3d, Color)
Draws a single dotted line.
Public methodDrawDottedPolyline
Draws a set of connected lines (polyline) in a dotted pattern (0x00001111).
Public methodDrawExtrusionWires(Extrusion, Color)
Draws all the wireframe curves of an extrusion object.
Public methodDrawExtrusionWires(Extrusion, Color, Int32)
Draws all the wireframe curves of an extrusion object.
Public methodDrawGradientHatch(Hatch, IEnumerableColorStop, Point3d, Point3d, Boolean, Single, DisplayPen, Color)
Public methodDrawGradientHatch(Hatch, IEnumerableColorStop, Point3d, Point3d, Boolean, Single, Single, Color)
Public methodDrawGradientHatch(Hatch, Color, Color, Point3d, Point3d, Boolean, Single, Color)
Draw a two point gradient filled hatch
Public methodDrawGradientLines
Public methodDrawGradientMesh
Public methodDrawHatch(Hatch, Color, Color)
Public methodDrawHatch(Hatch, Color, DisplayPen, Color)
Public methodDrawInstanceDefinition(InstanceDefinition)
Draws an InstanceDefinition.
Public methodDrawInstanceDefinition(InstanceDefinition, Transform)
Draws an InstanceDefinition.
Public methodDrawLight
Draws a light.
Public methodDrawLine(Line, DisplayPen)
Public methodDrawLine(Line, Color)
Draws a single line object.
Public methodDrawLine(Line, Color, Int32)
Draws a single line object.
Public methodDrawLine(Point3d, Point3d, Color)
Draws a single line object.
Public methodDrawLine(Point3d, Point3d, Color, Int32)
Draws a single line object.
Public methodDrawLineArrow
Draws an arrow made up of three line segments.
Public methodDrawLineNoClip
Draws a single line object .This version of line drawing will draw the segments of the line that extend beyond the near and far planes of the view frustum with depths on those planes
Public methodDrawLines(IEnumerableLine, Color)
Draws a set of lines with a given color and thickness. If you want the fastest possible set of lines to be drawn, pass a Line[] for lines.
Public methodDrawLines(Line, DisplayPen)
Public methodDrawLines(IEnumerableLine, Color, Int32)
Draws a set of lines with a given color and thickness. If you want the fastest possible set of lines to be drawn, pass a Line[] for lines.
Public methodDrawMarker(Point3d, Vector3d, Color)
Draws an arrow marker as a view-aligned widget.
Public methodDrawMarker(Point3d, Vector3d, Color, Int32)
Draws an arrow marker as a view-aligned widget.
Public methodDrawMarker(Point3d, Vector3d, Color, Int32, Double)
Draws an arrow marker as a view-aligned widget.
Public methodDrawMarker(Point3d, Vector3d, Color, Int32, Double, Double)
Draws an arrow marker as a view-aligned widget.
Public methodDrawMeshFalseColors
Draws the mesh faces as false color patches. The mesh must have Vertex Colors defined for this to work.
Public methodCode exampleDrawMeshShaded(Mesh, DisplayMaterial)
Draws the shaded faces of a given mesh.
Public methodDrawMeshShaded(Mesh, DisplayMaterial, Int32)
Draws the shaded faces of a given mesh.
Public methodDrawMeshVertices
Draws all the vertices in a given mesh.
Public methodCode exampleDrawMeshWires(Mesh, Color)
Draws all the wires in a given mesh.
Public methodDrawMeshWires(Mesh, Color, Int32)
Draws all the wires in a given mesh.
Public methodDrawObject(RhinoObject)
Draws a RhinoObject.
Public methodCode exampleDrawObject(RhinoObject, Transform)
Draws a RhinoObject with an applied transformation.
Public methodDrawParticles(ParticleSystem)
Public methodDrawParticles(ParticleSystem, DisplayBitmap)
Public methodDrawParticles(ParticleSystem, DisplayBitmap)
Public methodDrawPatternedLine(Line, Color, Int32, Int32)
Draws a single line with specified pattern.
Public methodDrawPatternedLine(Point3d, Point3d, Color, Int32, Int32)
Draws a single line with specified pattern.
Public methodDrawPatternedPolyline
Draws a set of connected lines (polyline) with specified pattern.
Public methodDrawPoint(Point3d)
Draws a point using the current display attribute size, style and color
Public methodDrawPoint(Point3d, Color)
Draws a point with a given radius, style and color.
Public methodDrawPoint(Point3d, PointStyle, Int32, Color)
Draws a point with a given radius, style and color.
Public methodDrawPoint(Point3d, PointStyle, Single, Color)
Draws a point with a given radius, style and color.
Public methodDrawPoint(Point3d, PointStyle, Color, Color, Single, Single, Single, Single, Boolean, Boolean)
Public methodDrawPointCloud(PointCloud, Int32)
Draws a point cloud.
Public methodDrawPointCloud(PointCloud, Single)
Draws a point cloud.
Public methodDrawPointCloud(PointCloud, Int32, Color)
Draws a point cloud.
Public methodDrawPointCloud(PointCloud, Single, Color)
Draws a point cloud.
Public methodDrawPoints(DisplayPointSet)
Public methodDrawPoints(DisplayPointSet, DisplayPointAttributes, DisplayPointAttributes)
Public methodDrawPoints(IEnumerablePoint3d, PointStyle, Int32, Color)
Draw a set of points with a given radius, style and color.
Public methodDrawPoints(IEnumerablePoint3d, PointStyle, Single, Color)
Draw a set of points with a given radius, style and color.
Public methodDrawPoints(IEnumerablePoint3d, PointStyle, Color, Color, Single, Single, Single, Single, Boolean, Boolean)
Public methodDrawPolygon
Draws a filled, convex polygon from a collection of points.
Public methodDrawPolyline(IEnumerablePoint3d, Color)
Draws a single Polyline object.
Public methodDrawPolyline(IEnumerablePoint3d, Color, Int32)
Draws a single Polyline object.
Public methodDrawRoundedRectangle
Public methodDrawSphere(Sphere, Color)
Draw a wireframe sphere.
Public methodDrawSphere(Sphere, Color, Int32)
Draw a wireframe sphere.
Public methodDrawSprite(DisplayBitmap, Point2d, Single)
Public methodDrawSprite(DisplayBitmap, Point2d, Single, Color)
Public methodDrawSprite(DisplayBitmap, Point2d, Single, Single)
Draw screen oriented image centered at 2d screen location
Public methodDrawSprite(DisplayBitmap, Point3d, Single, Boolean)
Public methodDrawSprite(DisplayBitmap, Point3d, Single, Color, Boolean)
Public methodDrawSprites(DisplayBitmap, DisplayBitmapDrawList, Single, Boolean)
Public methodDrawSprites(DisplayBitmap, DisplayBitmapDrawList, Single, Vector3d, Boolean)
Public methodDrawStereoFrameBuffer
Draws the viewport as seen from the left and the right eye viewports and returns the result as OpenGL texture handles.
Public methodDrawSubDShaded
Draw a shaded mesh representation of a SubD
Public methodDrawSubDWires(SubD, Color, Single)
Draws all the wireframe curves of a SubD object
Public methodDrawSubDWires(SubD, DisplayPen, DisplayPen, DisplayPen, DisplayPen)
Draws all the wireframe curves os a SubD object using different pens
Public methodDrawSurface
Draw wireframe display for a single surface.
Public methodDrawText(TextEntity, Color)
Public methodDrawText(TextEntity, Color, Transform)
Public methodDrawText(TextEntity, Color, Double)
Public methodStatic memberDrawToBitmap
Draw a given viewport to an off-screen bitmap.
Public methodDrawTorus(Torus, Color)
Draw a wireframe torus.
Public methodDrawTorus(Torus, Color, Int32)
Draw a wireframe torus.
Public methodDrawZebraPreview(Brep, Color)
Draws a shaded Brep with Zebra stripe preview.
Public methodDrawZebraPreview(Mesh, Color)
Draws a shaded Mesh with Zebra stripe preview.
Public methodEnableClippingPlanes
Enable or disable the Clipping Plane logic of the engine.
Public methodEnableColorWriting
Enable or disable the ColorWriting behavior of the engine.
Public methodEnableDepthTesting
Enable or disable the DepthTesting behavior of the engine. When DepthTesting is disabled, objects in front will no longer occlude objects behind them.
Public methodEnableDepthWriting
Enable or disable the DepthWriting behavior of the engine. When DepthWriting is disabled, drawn geometry does not affect the Z-Buffer.
Public methodEnableLighting
Enable or disable the Lighting logic of the engine.
Public methodFlush
Force the pipeline to immediately flush any cached geometry to the display
Public methodStatic memberGetDrawListSerialNumbers
Gets the current model and page view draw list serial numbers, which can be used to determine if a model or page view needs to be redrawn.
Public methodGetLights
Get lights that this pipeline is current using
Public methodGetOpenGLCameraToClip
Get an array of 16 floats that represents the "camera" to "clip" coordinate transformation in OpenGL's right handed coordinate system
Public methodGetOpenGLWorldToCamera
Get an array of 16 floats that represents the "world" to "camera" coordinate transformation in OpenGL's right handed coordinate system
Public methodGetOpenGLWorldToClip
Get an array of 16 floats that represents the "world" to "clip" coordinate transformation in OpenGL's right handed coordinate system
Public methodInterruptDrawing
Tests to see if the pipeline should stop drawing more geometry and just show what it has so far. If a drawing operation is taking a long time, this function will return true and tell Rhino it should just finish up and show the frame buffer. This is used in dynamic drawing operations.
Public methodIsActive
Determines if an object can be visible in this viewport based on it's object type and display attributes. This test does not check for visibility based on location of the object. NOTE: Use CRhinoDisplayPipeline::IsVisible() to perform "visibility" tests based on location (is some part of the object in the view frustum). Use CRhinoDisplayPipeline::IsActive() to perform "visibility" tests based on object type.
Public methodIsInTiledDraw
Returns true if the currently drawn frame is part of a tiled capture. Tiled captures are performed when creating large raster outputs.
Public methodIsVisible(BoundingBox)
Test a given box for visibility inside the view frustum under the current viewport and model transformation settings.
Public methodIsVisible(Point3d)
Test a given 3d world coordinate point for visibility inside the view frustum under the current viewport and model transformation settings.
Public methodIsVisible(RhinoObject)
Test a given object for visibility inside the view frustum under the current viewport and model transformation settings. This function calls a virtual IsVisibleFinal function that sub-classed pipelines can add extra tests to. In the base class, this test only tests visibility based on the objects world coordinates location and does not pay attention to the object's attributes. NOTE: Use CRhinoDisplayPipeline::IsVisible() to perform "visibility" tests based on location (is some part of the object in the view frustum). Use CRhinoDisplayPipeline::IsActive() to perform "visibility" tests based on object type.
Public methodStatic memberMakeDefaultOpenGLContextCurrent
Make a "default" OpenGL context current
Public methodMeasure2dText
Determines screen rectangle that would be drawn to using the Draw2dText(..) function with the same parameters.
Public methodOpen
Opens the pipeline.
Public methodPopClipTesting Obsolete.
Pop a ClipTesting flag off the engine's stack.
Public methodPopCullFaceMode
Pop a FaceCull flag off the engine's stack.
Public methodPopDepthTesting
Pop a DepthTesting flag off the engine's stack.
Public methodPopDepthWriting
Pop a DepthWriting flag off the engine's stack.
Public methodPopModelTransform
Pop a model transformation off the engine's model transform stack.
Public methodPopProjection
Pop a view projection off this pipelines projection stack
Public methodPush2dProjection
Push the current view projection and set the viewport up to be a simple 2D top projection where the camera frustum matches the same size as the screen port. This allows geometry draw functions to act like they are working with typical 2d graphics APIs on a window
Public methodPushClipTesting Obsolete.
Push a ClipTesting flag on the engine's stack.
Public methodPushCullFaceMode
Push a FaceCull flag on the engine's stack.
Public methodPushDepthTesting
Push a DepthTesting flag on the engine's stack.
Public methodPushDepthWriting
Push a DepthWriting flag on the engine's stack.
Public methodPushModelTransform
Push a model transformation on the engine's model transform stack.
Public methodRemoveClippingPlane
Remove a clipping plane from the pipeline for this frame
Public methodSetupDisplayMaterial(Color)
Public methodSetupDisplayMaterial(RhinoDoc, RhinoObject)
Sets up a display material.
Public methodSetupDisplayMaterial(RhinoDoc, RhinoObject, ObjectAttributes)
Sets up a display material.
Public methodSetupDisplayMaterial(RhinoDoc, RhinoObject, ObjectAttributes, Transform)
Sets up a display material.
Top
See Also