Click or drag to resize

DisplayPipelineDrawPolygon Method

Draws a filled, convex polygon from a collection of points.

Namespace:  Rhino.Display
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public void DrawPolygon(
	IEnumerable<Point3d> points,
	Color color,
	bool filled
)

Parameters

points
Type: System.Collections.GenericIEnumerablePoint3d
Collection of world coordinate points that are connected by lines to form a closed shape. Collection must contain at least 3 points.
color
Type: System.DrawingColor
Color to draw with.
filled
Type: SystemBoolean
true if the closed area should be filled with color. false if you want to draw just the border of the closed shape.
See Also