Click or drag to resize

DisplayPipelineDrawInferenceLine Method

Draw an inference line used in gesture based snapping

Namespace:  Rhino.Display
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public void DrawInferenceLine(
	Point3d P,
	Point3d O,
	Color color,
	DisplayPipelineInferenceLineType type
)

Parameters

P
Type: Rhino.GeometryPoint3d
First point used to define the line in world coordinates
O
Type: Rhino.GeometryPoint3d
Second point used to define the line in world coordinates
color
Type: System.DrawingColor
Color of line
type
Type: Rhino.DisplayDisplayPipelineInferenceLineType
Type of line DisplayPipelineInferenceLineType
See Also