Click or drag to resize

DisplayPipelineDrawLines Method (IEnumerableLine, Color, Int32)

Draws a set of lines with a given color and thickness. If you want the fastest possible set of lines to be drawn, pass a Line[] for lines.

Namespace:  Rhino.Display
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public void DrawLines(
	IEnumerable<Line> lines,
	Color color,
	int thickness
)

Parameters

lines
Type: System.Collections.GenericIEnumerableLine
Lines to draw.
color
Type: System.DrawingColor
Color to draw with.
thickness
Type: SystemInt32
Thickness (in pixels) of lines.
See Also