Click or drag to resize

DisplayPipelineDraw2dText Method (String, Color, Point3d, Boolean)

Draws 2D text on the viewport.

Namespace:  Rhino.Display
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public void Draw2dText(
	string text,
	Color color,
	Point3d worldCoordinate,
	bool middleJustified
)

Parameters

text
Type: SystemString
the string to draw.
color
Type: System.DrawingColor
text color.
worldCoordinate
Type: Rhino.GeometryPoint3d
definition point in world coordinates.
middleJustified
Type: SystemBoolean
if true text is centered around the definition point, otherwise it is lower-left justified.
See Also