Click or drag to resize

DisplayPipelineDraw2dText Method (String, Color, Point2d, Boolean, Int32, String)

Draws 2D text on the viewport.

Namespace:  Rhino.Display
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public void Draw2dText(
	string text,
	Color color,
	Point2d screenCoordinate,
	bool middleJustified,
	int height,
	string fontface
)

Parameters

text
Type: SystemString
the string to draw.
color
Type: System.DrawingColor
text color.
screenCoordinate
Type: Rhino.GeometryPoint2d
definition point in screen coordinates (0,0 is top-left corner)
middleJustified
Type: SystemBoolean
if true text is centered around the definition point, otherwise it is lower-left justified.
height
Type: SystemInt32
height in pixels (good default is 12)
fontface
Type: SystemString
font name (good default is "Arial")
See Also