Click or drag to resize

DisplayPipelineDrawMarker Method (Point3d, Vector3d, Color, Int32, Double, Double)

Draws an arrow marker as a view-aligned widget.

Namespace:  Rhino.Display
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public void DrawMarker(
	Point3d tip,
	Vector3d direction,
	Color color,
	int thickness,
	double size,
	double rotation
)

Parameters

tip
Type: Rhino.GeometryPoint3d
Location of arrow tip point.
direction
Type: Rhino.GeometryVector3d
Direction of arrow.
color
Type: System.DrawingColor
Color of arrow widget.
thickness
Type: SystemInt32
Thickness of arrow widget lines.
size
Type: SystemDouble
Size (in pixels) of the arrow shaft.
rotation
Type: SystemDouble
Rotational angle adjustment (in radians, counter-clockwise of direction.
See Also