NurbsSurface Methods |
The NurbsSurface type exposes the following members.
Name | Description | |
---|---|---|
ComponentIndex |
If this piece of geometry is a component in something larger, like a BrepEdge
ConvertSpanToBezier |
Convert a NURBS surface bispan into a Bezier surface.
| |
CopyFrom |
Copies this NURBS surface from another NURBS surface.
| |
Create |
Constructs a new NURBS surface with internal uninitialized arrays.
| |
CreateCurveOnSurface |
Fit a sequence of 2d points on a surface to make a curve on the surface.
| |
CreateCurveOnSurfacePoints |
Computes a discrete spline curve on the surface. In other words, computes a sequence
of points on the surface, each with a corresponding parameter value.
| |
CreateFromCone |
Constructs a new NURBS surfaces from cone data.
| |
CreateFromCorners(Point3d, Point3d, Point3d) |
Makes a surface from 3 corner points.
| |
CreateFromCorners(Point3d, Point3d, Point3d, Point3d) |
Makes a surface from 4 corner points.
This is the same as calling CreateFromCorners(Point3d, Point3d, Point3d, Point3d, Double) with tolerance 0. | |
CreateFromCorners(Point3d, Point3d, Point3d, Point3d, Double) |
Makes a surface from 4 corner points.
| |
CreateFromCylinder |
Constructs a new NURBS surfaces from cylinder data.
| |
CreateFromPlane |
Creates a NURBS surface from a plane and additional parameters.
| |
CreateFromPoints |
Constructs a NURBS surface from a 2D grid of control points.
| |
CreateFromSphere |
Constructs a new NURBS surfaces from sphere data.
| |
CreateFromTorus |
Constructs a new NURBS surfaces from torus data.
| |
CreateNetworkSurface(IEnumerableCurve, Int32, Double, Double, Double, Int32) |
Builds a surface from an auto-sorted network of curves/edges.
| |
CreateNetworkSurface(IEnumerableCurve, Int32, Int32, IEnumerableCurve, Int32, Int32, Double, Double, Double, Int32) |
Builds a surface from an ordered network of curves/edges.
| |
CreateRailRevolvedSurface |
Constructs a railed Surface-of-Revolution.
| |
CreateRuledSurface |
Constructs a ruled surface between two curves. Curves must share the same knot-vector.
| |
CreateSubDFriendly |
Create a bi-cubic SubD friendly surface from a surface.
| |
CreateThroughPoints |
Constructs a NURBS surface from a 2D grid of points.
DataCRC |
Returns a CRC calculated from the information that defines the object.
Degree |
Returns the maximum algebraic degree of any span
DuplicateShallow |
Constructs a light copy of this object. By "light", it is meant that the same
underlying data is used until something is done to attempt to change it. For example,
you could have a shallow copy of a very heavy mesh object and the same underlying
data will be used when doing things like inspecting the number of faces on the mesh.
If you modify the location of one of the mesh vertices, the shallow copy will create
a full duplicate of the underlying mesh data and the shallow copy will become a
EnsurePrivateCopy |
If you want to keep a copy of this class around by holding onto it in a variable after a command
completes, call EnsurePrivateCopy to make sure that this class is not tied to the document. You can
EpsilonEquals |
Check that all values in other are within epsilon of the values in this
| |
FindClosestIsoCurve |
Find the closest isoparamentric curve, given a test point.
| |
GetSurfaceSize |
Gets an estimate of the size of the rectangle that would be created
IncreaseDegreeU |
Increase the degree of this surface in U direction.
| |
IncreaseDegreeV |
Increase the degree of this surface in V direction.
IsValidWithLog |
Determines if an object is valid. Also provides a report on errors if this
LocalClosestPoint |
Find parameters of the point on a surface that is locally closest to
MakeCompatible |
For expert use only. Makes a pair of compatible NURBS surfaces based on two input surfaces.
MakeNonRational |
Makes this surface non-rational.
| |
MakeRational |
Makes this surface rational.
| |
MatchToCurve |
Constructs a NURBS surface with start and end edge isocurve matching the start and end of targetCurve, and Greville points on targetCurve.
| |
RefitSimplySplitSurface |
This routine accepts a 3-d trim curve (trimCrv3d).
The trim curve is assumed to run from one surface edge to the opposite edge;
this is referred to as a "simple" trim curve, roughly parallel to one of the
srf directions (either u or v). We refer to that parameter as the "trim parameter".
The routine splits the surface via the trim curve, and then refits either side
("upper" = "above the trim", and "lower" = "below the trim") as a set of
untrimmed Nurbs surfaces. The idea is to retain, as much as possible, the
Reverse(Int32, Boolean) |
Same as Reverse, but if inPlace is set to true this Surface is modified
Rotate |
Rotates the object about the specified axis. A positive rotation
ToNurbsSurface |
Gets a NURBS surface representation of this surface. Default
Transform |
Transforms the geometry. If the input Transform has a SimilarityType of
OrientationReversing, you may want to consider flipping the transformed
geometry after calling this function when it makes sense. For example,
UVNDirectionsAt |
Calculates the U, V, and N directions of a NURBS surface at a u,v parameter similar to the method used by Rhino's MoveUVN command.