Click or drag to resize

NurbsSurfaceCreateFromPoints Method

Constructs a NURBS surface from a 2D grid of control points.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public static NurbsSurface CreateFromPoints(
	IEnumerable<Point3d> points,
	int uCount,
	int vCount,
	int uDegree,
	int vDegree
)

Parameters

points
Type: System.Collections.GenericIEnumerablePoint3d
Control point locations.
uCount
Type: SystemInt32
Number of points in U direction.
vCount
Type: SystemInt32
Number of points in V direction.
uDegree
Type: SystemInt32
Degree of surface in U direction.
vDegree
Type: SystemInt32
Degree of surface in V direction.

Return Value

Type: NurbsSurface
A NurbsSurface on success or null on failure.
Remarks
uCount multiplied by vCount must equal the number of points supplied.
See Also