Click or drag to resize

NurbsSurfaceCreateRailRevolvedSurface Method

Constructs a railed Surface-of-Revolution.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public static NurbsSurface CreateRailRevolvedSurface(
	Curve profile,
	Curve rail,
	Line axis,
	bool scaleHeight
)

Parameters

profile
Type: Rhino.GeometryCurve
Profile curve for revolution.
rail
Type: Rhino.GeometryCurve
Rail curve for revolution.
axis
Type: Rhino.GeometryLine
Axis of revolution.
scaleHeight
Type: SystemBoolean
If true, surface will be locally scaled.

Return Value

Type: NurbsSurface
A NurbsSurface or null on failure.
See Also