NurbsSurfaceCreateFromCorners Method (Point3d, Point3d, Point3d) |
Makes a surface from 3 corner points.
Namespace:
Rhino.Geometry
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public static NurbsSurface CreateFromCorners(
Point3d corner1,
Point3d corner2,
Point3d corner3
)
Public Shared Function CreateFromCorners (
corner1 As Point3d,
corner2 As Point3d,
corner3 As Point3d
) As NurbsSurface
Parameters
- corner1
- Type: Rhino.GeometryPoint3d
The first corner. - corner2
- Type: Rhino.GeometryPoint3d
The second corner. - corner3
- Type: Rhino.GeometryPoint3d
The third corner.
Return Value
Type:
NurbsSurfaceThe resulting surface or null on error.
See Also