Click or drag to resize

BrepFace Methods

The BrepFace type exposes the following members.

Methods
  NameDescription
Public methodAdjacentEdges
Gets the indices of all the BrepEdges that delineate this Face.
Public methodAdjacentFaces
Gets the indices of all the BrepFaces that surround (are adjacent to) this face.
Public methodChangeSurface
Expert user tool that replaces the 3d surface geometry use by the face.
Public methodClearMaterialChannelIndex
Clear this face's rendering material channel index.
Public methodClearPackId
Sets BrepFace.PackId to 0.
Public methodCreateExtrusion
Extrude a face in a Brep.
Public methodDraftAnglePoint
Returns the surface draft angle and point at a parameter.
Public methodDuplicateFace
Duplicate a face from the brep to create new single face brep.
Public methodDuplicateSurface
Gets a copy to the untrimmed surface that this face is based on.
Public methodFilletSurfaceToCurve
Creates a constant-radius fillet surface between a surface and the curve.
Public methodFilletSurfaceToRail
Creates a surface between two surfaces, with a fixed rail curve on the first surface.
Public methodGetMesh
Obtains a reference to a specified type of mesh for this brep face.
Public methodIsPointOnFace(Double, Double)
Tests if a parameter space point is in the active region of a face.
Public methodIsPointOnFace(Double, Double, Double)
Tests if a parameter space point is in the active region of a face.
Public methodPullPointsToFace
Pulls one or more points to a brep face.
Public methodRebuildEdges
Rebuild the edges used by a face so they lie on the surface.
Public methodRefitTrim
The RefitTrim command replaces a trimmed surface edge with an untrimmed edge.
Public methodRemoveHoles
Remove all inner loops, or holes, from a Brep face.
Public methodSetDomain
Sets the surface domain of this face.
(Overrides SurfaceSetDomain(Int32, Interval).)
Public methodSetMesh
Sets a reference to a specified type of mesh for this brep face.
Public methodSetPackId
Used by SubD functions that create breps to transmit the subd face SubDFace.PackId value to the brep face or faces generated from the subd face. Unless you are an expert and doing something very carefully and very fancy, to not call this function.
Public methodShrinkFace
Shrinks the underlying untrimmed surface of this Brep face close to trimming boundaries. Shrinking a surface is like extending smoothly, only backwards. knot of full multiplicity are added where you want the surface to be cut off. Then the remaining control points are thrown away.
Public methodShrinkSurfaceToEdge
Shrinks the underlying untrimmed surface of this Brep face right to the trimming boundaries. Note, shrinking the trimmed surface can sometimes cause problems later since having the edges so close to the trimming boundaries can cause commands that use the surface edges as input to fail.
Public methodCode exampleSplit(IEnumerableCurve, Double)
Split this face using 3D trimming curves.
Public methodTrimAwareIsoCurve
Similar to IsoCurve function, except this function pays attention to trims on faces and may return multiple curves.
Public methodTrimAwareIsoIntervals
Gets intervals where the iso curve exists on a BrepFace (trimmed surface)
Public methodUnderlyingSurface
Gets the untrimmed surface that is the base of this face.
Top
See Also