Click or drag to resize

BrepFaceIsPointOnFace Method (Double, Double, Double)

Tests if a parameter space point is in the active region of a face.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 7.0
Syntax
public PointFaceRelation IsPointOnFace(
	double u,
	double v,
	double tolerance
)

Parameters

u
Type: SystemDouble
Parameter space point U value.
v
Type: SystemDouble
Parameter space point V value.
tolerance
Type: SystemDouble
3D tolerance used when checking to see if the point is on a face or inside of a loop.

Return Value

Type: PointFaceRelation
A value describing the relationship between the point and the face.
See Also