Click or drag to resize

PersistentSettings Class

A dictionary of SettingValue items.
Inheritance Hierarchy
SystemObject
  RhinoPersistentSettings

Namespace:  Rhino
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public class PersistentSettings : ISerializable

The PersistentSettings type exposes the following members.

Constructors
  NameDescription
Protected methodPersistentSettings
Initializes a new instance of the PersistentSettings class
Top
Properties
  NameDescription
Public propertyChildKeys
Gets a collection containing the keys in the settings dictionary.
Public propertyHiddenFromUserInterface
If false then values will appear in the EditOptions window
Public propertyKeys
Gets a collection containing the keys in the settings dictionary.
Public propertyStatic memberRhinoAppSettings
Public propertyStatic memberStringListRootKey
Adding this string to a string list when calling SetStringList will cause the ProgramData setting to get inserted at that location in the list.
Top
Methods
  NameDescription
Public methodAddChild
Call this method to add a new child key, if the key is exists then the existing key is returned otherwise a new empty PersistentSettings child key is added and the new settings are returned.
Public methodClearChangedFlag
Public methodContainsChangedValues
Public methodContainsModifiedValues
Public methodDeleteChild
Call this method to delete a child settings key.
Public methodDeleteItem
Public methodStatic memberFromPlugInId
Public methodGetBool(String)
Public methodGetBool(String, Boolean)
Public methodGetBool(String, Boolean, IEnumerableString)
Public methodGetByte(String)
Public methodGetByte(String, Byte)
Public methodGetByte(String, Byte, IEnumerableString)
Public methodGetChar(String)
Public methodGetChar(String, Char)
Public methodGetChar(String, Char, IEnumerableString)
Public methodGetChild
Call this method to get a nested settings PersistentSettings instance, will throw a KeyNotFoundException exception if the key does not exist.
Public methodGetColor(String)
Public methodGetColor(String, Color)
Public methodGetColor(String, NullableColor)
Public methodGetColor(String, Color, IEnumerableString)
Public methodGetColor(String, NullableColor, IEnumerableString)
Public methodGetDate(String)
Public methodGetDate(String, DateTime)
Public methodGetDate(String, DateTime, IEnumerableString)
Public methodGetDouble(String)
Public methodGetDouble(String, Double)
Public methodGetDouble(String, Double, IEnumerableString)
Public methodGetEnumValueT(T)
Get a stored enumerated value, or return default value if not found
Public methodGetEnumValueT(String)
Get a stored enumerated value using a custom key.
Public methodGetEnumValueT(String, T)
Gets a stored enumerated value using a custom key, or return default value if not found.
Public methodGetGuid(String)
Public methodGetGuid(String, Guid)
Public methodGetGuid(String, Guid, IEnumerableString)
Public methodGetInteger(String)
Public methodGetInteger(String, Int32)
Public methodGetInteger(String, Int32, IEnumerableString)
Public methodGetInteger(String, Int32, Int32, Boolean)
Public methodGetInteger(String, Int32, Int32, Int32)
Public methodGetPoint(String)
Public methodGetPoint(String, Point)
Public methodGetPoint(String, Point, IEnumerableString)
Public methodGetPoint3d(String)
Public methodGetPoint3d(String, Point3d)
Public methodGetPoint3d(String, Point3d, IEnumerableString)
Public methodGetRectangle(String)
Public methodGetRectangle(String, Rectangle)
Public methodGetRectangle(String, Rectangle, IEnumerableString)
Public methodGetSettingIsHiddenFromUserInterface(String)
Values read from all users settings files will be marked as read-only which will cause any future calls to Set... to fail.
Public methodGetSettingIsHiddenFromUserInterface(String, IEnumerableString)
Values read from all users settings files will be marked as read-only which will cause any future calls to Set... to fail.
Public methodGetSettingIsReadOnly
Values read from all users settings files will be marked as read-only which will cause any future calls to Set... to fail.
Public methodGetSettingType
Gets the type of the last value passed to Set... or Get... for the specified setting.
Public methodGetSize(String)
Public methodGetSize(String, Size)
Public methodGetSize(String, Size, IEnumerableString)
Public methodGetString(String)
Public methodGetString(String, String)
Public methodGetString(String, String, IEnumerableString)
Public methodGetStringDictionary(String)
Public methodGetStringDictionary(String, KeyValuePairString, String)
Public methodGetStringDictionary(String, KeyValuePairString, String, IEnumerableString)
Public methodGetStringList(String)
Public methodGetStringList(String, String)
Public methodGetStringList(String, String, IEnumerableString)
Public methodGetUnsignedInteger(String)
Public methodGetUnsignedInteger(String, UInt32)
Public methodGetUnsignedInteger(String, UInt32, IEnumerableString)
Public methodGetValidatorT
Provides a way to find a ready-to-use validator for the PersistentSetting class for the given the key, or obtaining null.
Public methodHideSettingFromUserInterface
Public methodRegisterSettingsValidatorT
Sets a validator for a given key.

Note to implementers: T should be one of the supported types for the PersistentSettings class and should match the type associated with the key.

This method allows to use anonymous methods and lambda expressions.

Public methodSetBool
Public methodSetByte
Public methodSetChar
Public methodSetColor(String, Color)
Public methodSetColor(String, NullableColor)
Public methodSetDate
Public methodSetDefault(String, Point3d)
Public methodSetDefault(String, Boolean)
Public methodSetDefault(String, Byte)
Public methodSetDefault(String, Char)
Public methodSetDefault(String, KeyValuePairString, String)
Public methodSetDefault(String, DateTime)
Public methodSetDefault(String, Double)
Public methodSetDefault(String, Color)
Public methodSetDefault(String, Point)
Public methodSetDefault(String, Rectangle)
Public methodSetDefault(String, Size)
Public methodSetDefault(String, Guid)
Public methodSetDefault(String, Int32)
Public methodSetDefault(String, NullableColor)
Public methodSetDefault(String, String)
Public methodSetDefault(String, String)
Public methodSetDouble
Public methodSetEnumValueT(T)
Set an enumerated value in the settings.
Public methodSetEnumValueT(String, T)
Set an enumerated value in the settings using a custom key
Public methodSetGuid
Public methodSetInteger
Public methodSetPoint
Public methodSetPoint3d
Public methodSetRectangle
Public methodSetSize
Public methodSetString
Public methodSetStringDictionary
Public methodSetStringList
Including a item with the value of StringListRootKey will cause the ProgramData value to get inserted at that location in the list when calling GetStringList.
Public methodSetUnsignedInteger
Public methodTryGetBool(String, Boolean)
Public methodTryGetBool(String, Boolean, IEnumerableString)
Public methodTryGetByte(String, Byte)
Public methodTryGetByte(String, Byte, IEnumerableString)
Public methodTryGetChar(String, Char)
Public methodTryGetChar(String, Char, IEnumerableString)
Public methodTryGetChild
Call this method to get a nested settings PersistentSettings instance, will return true if the key exists and value was set otherwise; will return false and value will be set to null.
Public methodTryGetColor(String, Color)
Public methodTryGetColor(String, NullableColor)
Public methodTryGetColor(String, Color, IEnumerableString)
Public methodTryGetColor(String, NullableColor, IEnumerableString)
Public methodTryGetDate(String, DateTime)
Public methodTryGetDate(String, DateTime, IEnumerableString)
Public methodTryGetDefault(String, Point3d)
Public methodTryGetDefault(String, Boolean)
Public methodTryGetDefault(String, Byte)
Public methodTryGetDefault(String, Char)
Public methodTryGetDefault(String, DateTime)
Public methodTryGetDefault(String, Double)
Public methodTryGetDefault(String, Color)
Public methodTryGetDefault(String, Rectangle)
Public methodTryGetDefault(String, Size)
Public methodTryGetDefault(String, Int32)
Public methodTryGetDefault(String, String)
Public methodTryGetDefault(String, String)
Public methodTryGetDouble(String, Double)
Public methodTryGetDouble(String, Double, IEnumerableString)
Public methodTryGetEnumValueT
Attempt to get the stored value for an enumerated setting using a custom key. Note: the enumerated value ALWAYS gets assigned! Be sure to check for success of this method to prevent erroneous use of the value.
Public methodTryGetGuid(String, Guid)
Public methodTryGetGuid(String, Guid, IEnumerableString)
Public methodTryGetInteger(String, Int32)
Public methodTryGetInteger(String, Int32, IEnumerableString)
Public methodTryGetPoint(String, Point)
Public methodTryGetPoint(String, Point, IEnumerableString)
Public methodTryGetPoint3d(String, Point3d)
Public methodTryGetPoint3d(String, Point3d, IEnumerableString)
Public methodTryGetRectangle(String, Rectangle)
Public methodTryGetRectangle(String, Rectangle, IEnumerableString)
Public methodTryGetSettingIsHiddenFromUserInterface(String, Boolean)
Values read from all users settings files will be marked as read-only which will cause any future calls to Set... to fail.
Public methodTryGetSettingIsHiddenFromUserInterface(String, Boolean, IEnumerableString)
Values read from all users settings files will be marked as read-only which will cause any future calls to Set... to fail.
Public methodTryGetSettingIsReadOnly
Values read from all users settings files will be marked as read-only which will cause any future calls to Set... to fail.
Public methodTryGetSettingType
Get the type of the last value passed to Set... or Get... for the specified setting.
Public methodTryGetSize(String, Size)
Public methodTryGetSize(String, Size, IEnumerableString)
Public methodTryGetString(String, String)
Public methodTryGetString(String, String, IEnumerableString)
Public methodTryGetStringDictionary(String, KeyValuePairString, String)
Public methodTryGetStringDictionary(String, KeyValuePairString, String, IEnumerableString)
Public methodTryGetStringList(String, String)
Public methodTryGetStringList(String, String, IEnumerableString)
Public methodTryGetUnsignedInteger(String, UInt32)
Public methodTryGetUnsignedInteger(String, UInt32, IEnumerableString)
Top
See Also