Click or drag to resize

PersistentSettingsRegisterSettingsValidatorT Method

Sets a validator for a given key.

Note to implementers: T should be one of the supported types for the PersistentSettings class and should match the type associated with the key.

This method allows to use anonymous methods and lambda expressions.

Namespace:  Rhino
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public void RegisterSettingsValidator<T>(
	string key,
	EventHandler<PersistentSettingsEventArgs<T>> validator
)

Parameters

key
Type: SystemString
The key to which to bind the validator.
validator
Type: SystemEventHandlerPersistentSettingsEventArgsT
A validator instance of your own class.

Type Parameters

T
See Also