PersistentSettingsGetValidatorT Method |
Provides a way to find a ready-to-use validator for the
PersistentSetting class for the given the key, or obtaining null.
Namespace:
Rhino
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public EventHandler<PersistentSettingsEventArgs<T>> GetValidator<T>(
string key
)
Public Function GetValidator(Of T) (
key As String
) As EventHandler(Of PersistentSettingsEventArgs(Of T))
Parameters
- key
- Type: SystemString
The name of the setting key.
Type Parameters
- T
- The type that the validator acts upon.
Return Value
Type:
EventHandlerPersistentSettingsEventArgsTA valid validator, or null if no validator was found.
Exceptions See Also