Click or drag to resize

PersistentSettingsGetString Method (String, String, IEnumerableString)

[Missing <summary> documentation for "M:Rhino.PersistentSettings.GetString(System.String,System.String,System.Collections.Generic.IEnumerable{System.String})"]

Namespace:  Rhino
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.0
Syntax
public string GetString(
	string key,
	string defaultValue,
	IEnumerable<string> legacyKeyList
)

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Rhino.PersistentSettings.GetString(System.String,System.String,System.Collections.Generic.IEnumerable{System.String})"]

defaultValue
Type: SystemString

[Missing <param name="defaultValue"/> documentation for "M:Rhino.PersistentSettings.GetString(System.String,System.String,System.Collections.Generic.IEnumerable{System.String})"]

legacyKeyList
Type: System.Collections.GenericIEnumerableString

[Missing <param name="legacyKeyList"/> documentation for "M:Rhino.PersistentSettings.GetString(System.String,System.String,System.Collections.Generic.IEnumerable{System.String})"]

Return Value

Type: String

[Missing <returns> documentation for "M:Rhino.PersistentSettings.GetString(System.String,System.String,System.Collections.Generic.IEnumerable{System.String})"]

See Also