Click or drag to resize

PersistentSettingsGetEnumValueT Method (String)

Get a stored enumerated value using a custom key.

Namespace:  Rhino
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.4
Syntax
public T GetEnumValue<T>(
	string key
)
where T : struct, new(), IConvertible

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Rhino.PersistentSettings.GetEnumValue``1(System.String)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Rhino.PersistentSettings.GetEnumValue``1(System.String)"]

Return Value

Type: T

[Missing <returns> documentation for "M:Rhino.PersistentSettings.GetEnumValue``1(System.String)"]

Exceptions
ExceptionCondition
KeyNotFoundException
See Also