Click or drag to resize

PersistentSettingsGetEnumValueT Method (String, T)

Gets a stored enumerated value using a custom key, or return default value if not found.

Namespace:  Rhino
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.4
Syntax
public T GetEnumValue<T>(
	string key,
	T defaultValue
)
where T : struct, new(), IConvertible

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Rhino.PersistentSettings.GetEnumValue``1(System.String,``0)"]

defaultValue
Type: T

[Missing <param name="defaultValue"/> documentation for "M:Rhino.PersistentSettings.GetEnumValue``1(System.String,``0)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Rhino.PersistentSettings.GetEnumValue``1(System.String,``0)"]

Return Value

Type: T

[Missing <returns> documentation for "M:Rhino.PersistentSettings.GetEnumValue``1(System.String,``0)"]

See Also