Click or drag to resize

PersistentSettingsSetEnumValueT Method (String, T)

Set an enumerated value in the settings using a custom key

Namespace:  Rhino
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.4
Syntax
public void SetEnumValue<T>(
	string key,
	T value
)
where T : struct, new(), IConvertible

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Rhino.PersistentSettings.SetEnumValue``1(System.String,``0)"]

value
Type: T

[Missing <param name="value"/> documentation for "M:Rhino.PersistentSettings.SetEnumValue``1(System.String,``0)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Rhino.PersistentSettings.SetEnumValue``1(System.String,``0)"]

See Also