Click or drag to resize

BinaryArchiveWriter Methods

The BinaryArchiveWriter type exposes the following members.

Methods
  NameDescription
Public methodBeginWrite3dmChunk(UInt32, Int64)
Begins writing a chunk
Public methodBeginWrite3dmChunk(UInt32, Int32, Int32)
Begins writing a chunk
Public methodEnableCRCCalculation
Expert user function to control CRC calculation while reading and writing. Typically this is used when seeking around and reading/writing information in non-serial order.
Public methodEndWrite3dmChunk
updates length in chunk header
Public methodWrite3dmChunkVersion
A chunk version is a single byte that encodes a major.minor version number. Useful when creating I/O code for 3dm chunks that may change in the future. Increment the minor version number if new information is added to the end of the chunk. Increment the major version if the format of the chunk changes in some other way.
Public methodWriteBool
Writes a Boolean value to the archive.
Public methodWriteBoolArray
Writes a list, an array, or any enumerable of Boolean to the archive.

The return will always be an array.

Public methodWriteBoundingBox
Writes a BoundingBox value to the archive.
Public methodWriteByte
Writes a Byte value to the archive.
Public methodWriteByteArray
Writes a list, an array, or any enumerable of Byte to the archive.

The return will always be an array.

Public methodWriteColor
Writes a Color value to the archive.
Public methodWriteCompressedBuffer
Writes a list, an array, or any enumerable of Byte to the archive as a compressed buffer.

The return will always be an array.

Public methodWriteDictionary
Delivers the complete content of a dictionary to the archive.
Public methodWriteDouble
Writes a Double value to the archive.
Public methodWriteDoubleArray
Writes a list, an array, or any enumerable of Double to the archive.

The return will always be an array.

Public methodWriteFont
Writes a Font value to the archive.
Public methodWriteGeometry
Writes a GeometryBase value to the archive.
Public methodWriteGeometryArray
Public methodWriteGuid
Writes a Guid value to the archive.
Public methodWriteGuidArray
Writes a list, an array, or any enumerable of Guid to the archive.

The return will always be an array.

Public methodWriteInt
Writes a Int32 value to the archive.
Public methodWriteInt64
Writes a Int64 value to the archive.
Public methodWriteIntArray
Writes a list, an array, or any enumerable of Int32 to the archive.

The return will always be an array.

Public methodWriteInterval
Writes a Interval value to the archive.
Public methodWriteLine
Writes a Line value to the archive.
Public methodWriteMeshingParameters
Writes a MeshingParameters value to the archive.
Public methodWriteObjRef
Writes a ObjRef to the archive
Public methodWriteObjRefArray
Writes a list, an array, or any enumerable of ObjRef to the archive.

The return will always be an array.

Public methodWritePlane
Writes a Plane value to the archive.
Public methodWritePoint
Writes a Point value to the archive.
Public methodWritePoint2d
Writes a Point2d value to the archive.
Public methodWritePoint3d
Writes a Point3d value to the archive.
Public methodWritePoint3f
Writes a Point3f value to the archive.
Public methodWritePoint4d
Writes a Point4d value to the archive.
Public methodWritePointF
Writes a PointF value to the archive.
Public methodWriteRay3d
Writes a Ray3d value to the archive.
Public methodWriteRectangle
Writes a Rectangle value to the archive.
Public methodWriteRectangleF
Writes a RectangleF value to the archive.
Public methodWriteRenderSettings
Writes a RenderSettings value to the archive.
Public methodWriteSByte
Writes a SByte value to the archive.
Public methodWriteSByteArray
Writes a list, an array, or any enumerable of SByte to the archive.

The return will always be an array.

Public methodWriteShort
Writes a Int16 value to the archive.
Public methodWriteShortArray
Writes a list, an array, or any enumerable of Int16 to the archive.

The return will always be an array.

Public methodWriteSingle
Writes a Single value to the archive.
Public methodWriteSingleArray
Writes a list, an array, or any enumerable of Single to the archive.

The return will always be an array.

Public methodWriteSize
Writes a Size value to the archive.
Public methodWriteSizeF
Writes a SizeF value to the archive.
Public methodWriteString
Writes a String value to the archive.
Public methodWriteStringArray
Writes a list, an array, or any enumerable of String to the archive.

The return will always be an array.

Public methodWriteTransform
Writes a Transform value to the archive.
Public methodWriteUInt
Writes a UInt32 value to the archive.
Public methodWriteUShort
Writes a UInt16 value to the archive.
Public methodWriteUtf8String
Writes a String value to the archive.
Public methodWriteVector2d
Writes a Vector2d value to the archive.
Public methodWriteVector3d
Writes a Vector3d value to the archive.
Public methodWriteVector3f
Writes a Vector3f value to the archive.
Top
See Also